Оглавление

БАЗА ДАННЫХ "ПРОМЫШЛЕННОСТЬ РОССИИ И БЛИЖНЕГО ЗАРУБЕЖЬЯ"

(с) 2011, ЗАО "АСУ-Импульс"

Начало работы

Главное окно системы

Поиск

Печать

Форматный вывод

Авторы и разработчики


Главное окно системы

Главное окно системы может содержать один из трех списков предприятий:

· основной список полный список предприятий, информация о которых представлена в системе. Открывается при запуске программы или после нажатия кнопки "Основной список";
· рабочий список содержит предприятия основного списка, выбранные пользователем. Информацию о предприятиях этого списка можно распечатать, вывести в текстовый файл или на наклейки;
· список результатов поиска содержит предприятия, найденные в результате поиска по различным критериям.

Информация о предприятиях каждого списка представлена следующим образом:

· в левой части экрана указано наименование предприятия;
· в правой части вся имеющаяся информация конкретного предприятия.

Основной список можно отсортировать (пункт меню "Файл \ Сортировать по") по одному из параметров:

· наименованию;
· почтовому индексу;
· государству;
· отрасли.

Сортировка, установленная в основном списке, сохраняется для рабочего списка и списка результатов поиска.

Предприятия, информацию о которых нужно распечатать, вывести в текстовый файл или на наклейки, необходимо включить в рабочий список. Предприятие включается в рабочий список, если на его названии дважды щелкнуть мышью или нажать клавишу Ins на клавиатуре, а так же с помощью пунктов главного меню "Отбор \ Отметить/Снять", "Отбор \ Все". При этом названия предприятий, включенных в рабочий список отмечаются цветом.

Отменить включение предприятия в рабочий список можно повторным двойным щелчком мыши на названии предприятия, клавишей Ins на клавиатуре или с помощью пунктов главного меню "Отбор \ Отметить/Снять", "Отбор \ Снять все".

См. также

Поиск

Печать

Форматный вывод


Об авторах

Авторы и разработчики

База данных подготовлена авторским коллективом ЗАО "АСУ-Импульс"

Замечания и пожелания по работе с программой просим направлять по адресу:

125459, Россия, Москва, пр. Донелайтиса, 38

или по E-mail :asuimp@dol.ru

БАЗА ДАННЫХ "ПРОМЫШЛЕННОСТЬ РОССИИ И БЛИЖНЕГО ЗАРУБЕЖЬЯ"

Разработчик: (с) 2011, ЗАО "АСУ-Импульс"

Все права на размножение и распространение в любой форме остаются за разработчиком.

Нелегальное копирование и использование данного продукта запрещено.

ЗАО "АСУ-Импульс":

125459, Россия, Москва, пр. Донелайтиса, 38

Тел.: (495) 949-61-20, 949-59-11, 949-35-64

E-mail:asuimp@dol.ru

Интернет-магазин: http://www.asuimp.com, E-mail: sale@asuimp.com


Начало работы

Если в вашей системе не отключена функция Автозапуск, то программа запустится автоматически после установки диска в CD-ROM дисковод

Программу можно запустить так же с помощью ярлыка - во время установки программы Промышленность России и ближнего зарубежья на вашем компьютере создается ярлык для запуска программы:

нажмите кнопку Пуск (Start), выберите Программы... (Programms...), Промышленность России, Промышленность России и ближнего зарубежья; диск с программой должен быть установлен в CD-ROM дисковод.

Следует помнить, что для нормальной работы программы требуется около 10 Мб свободного места на жестком диске компьютера.

См. также

Главное окно системы

Поиск

Печать

Форматный вывод


Поиск

Окно "Шаблон поиска" вызывается из главного окна программы с помощью кнопки "Найти" или пункта меню "Отбор \ Найти".

Для того, чтобы отобрать предприятия по требуемым критериям нужно заполнить одно или несколько из предлагаемых полей и нажать кнопку "Начать". Формировать запрос поиска нужно по следующим правилам:

· в каждое поле можно ввести одно или несколько ключевых слов. Ключевые слова можно разделять служебными словами И, ИЛИ, а так же символом Пробел;
· в ключевых словах можно использовать служебные символы:

"*" (заменяет несколько любых символов в ключевом слове)

"?" (заменяет один символ в ключевом слове);

· при формировании запроса можно использовать как заглавные, так и строчные буквы;
· для полей Наименование, Форма собственности, Государство, Область, Район, Город, Отрасль, Продукция искомые значения можно выбрать из встроенных справочников. Для вызова справочника нужно нажать кнопку, [image] расположенную справа от поля. В справочнике необходимо найти и отметить требуемые значения (клавиша F3 - поиск следующего значения), после чего вернуться в шаблон поиска;
· возможен комбинированный поиск ввод ключевых слов с одновременным использованием значений справочника;
· для полей - Форма собственности, Государство, Отрасль - можно выбрать нужное значение из соответствующего выпадающего списка;
· для каждого поля можно использовать логическую операцию НЕ перед каждым из полей предусмотрена соответствующая кнопка;
· логическое отношение между задаваемыми полями определяется в нижней части окна "Шаблон поиска". По умолчанию между полями установлена операция И.

Очистить все поля от ранее введенной информации можно с помощью кнопки "Очистить поля". Кнопка "Очистить поле" очищает поле, в котором установлен курсор.

Рассмотрим примеры формирования шаблона для поиска:

1. Простой поиск по одному полю

Поле "Государство" шаблон для поиска Россия

Результатом отбора будут все предприятия базы данных, располагающиеся в России. Ключевое слово Россия можно набрать в поле "Государство" вручную или выбрать из выпадающего списка.

2. Поиск по нескольким полям с использованием логической операции НЕ и логического отношения между полями И

Поле "Государство" шаблон для поиска Россия

Поле "Город" шаблон для поиска НЕ Москва

Логическое отношение между полями - И

Результатом отбора будут все предприятия базы данных, располагающиеся в России, но не в Москве. Функция НЕ задается фиксированием соответствующей кнопки перед полем "Город". Логическое отношение между полями И задано в нижней части окна "Шаблон поиска" по умолчанию.

3. Поиск с использованием ключевого слова и служебного символа *

Поле "Наименование" шаблон для поиска ЭЛЕКТРОМЕХ*

Результатом отбора будут все предприятия базы данных, в названии которых встречаются слова ЭЛЕКТРОМЕХаника, ЭЛЕКТРОМХанический и т.д. Символ "*" заменяет все возможные окончания ключевого слова.

4. Поиск с использованием служебного символа *

Поле "Телефакс" шаблон для поиска *

Результатом отбора будут все предприятия базы данных, для которых указан номер телефакса. Символ "*" заменяет любую значимую информацию.

5. Комбинированный поиск с использованием ключевых слов, логического отношения между полями и служебного символа *

Поле "Город" шаблон для поиска Москва

Поле "Телефакс" шаблон для поиска *

Поле "Продукция" шаблон для поиска хлеб*

Логическое отношение между полями - И

Результатом отбора будут все предприятия базы данных, располагающиеся в Москве, для которых указан номер телефакса, и выпускающие ХЛЕБ, ХЛЕБобулочные изделия, оборудование ХЛЕБопекарное и т.д.

6. Поиск по нескольким полям с использованием логического отношения между полями ИЛИ

Поле "Город" шаблон для поиска Москва

Поле "Область" шаблон для поиска Московская

Логическое отношение между полями ИЛИ

Результатом отбора будут все предприятия базы данных, располагающиеся в Москве или в Московской области.

Если критерии запроса для поиска были сформированы некорректно, то на экране будет сообщение: "Не найдено ни одной записи". В этом случае необходимо откорректировать параметры поиска и повторить операцию.

Результатом поиска является список, состоящий из предприятий, удовлетворяющих критериям поиска.

Количество найденных предприятий указано в нижней части окна.

Все предприятия этого списка или часть из них можно включить в рабочий список (двойной щелчок на названии предприятия, клавиша Ins, пункты главного меню "Отбор \ Отметить/Снять", "Отбор \ Все", "Отбор \ Снять все").

Для перехода к рабочему списку можно воспользоваться кнопкой "Рабочий список".

Для проведения повторного поиска нужно вернуться к основному списку (кнопка "Основной список") и вновь вызвать окно "Шаблон поиска".

См. также:

Печать

Форматный вывод


Печать

Этот режим предназначен для вывода информации о предприятиях из рабочего списка на принтер или в текстовый файл. Данные о предприятиях могут выводиться полностью или частично (отобранные поля).

Для вызова режима печати нужно перейти к рабочему списку (кнопка "Рабочий список" главного окна) и нажать кнопку "Печать" или выбрать пункт меню "Файл \ Печать".

В окне "Печать" можно указать наименование и размер шрифта, которым будет производиться печать, направление вывода информации, определить состав выводимых полей, воспользоваться функцией предварительного просмотра. Кнопка "Печать" активизирует процесс печати или вывода в текстовый файл, кнопка "Отмена" позволяет отказаться от печати и перейти в главное окно программы.

В разделе "Шрифт" окна "Печать" можно задать наименование шрифта, которым будет производиться печать, и его размер. Выбор наименования шрифта производится из списка доступных для печати шрифтов, размер шрифта можно установить в интервале от 4 до 72 пунктов.

Направление вывода информации указывается в разделе "Вывод" окна "Печать".

Можно выбрать один из пунктов:

· Печать информация о предприятиях будет выведена на принтер, который используется в вашей системе по умолчанию;
· Вывод в файл информация будет выведена в текстовый файл, который впоследствии можно обработать в одном из текстовых редакторов (например, MsWord). После нажатия кнопки "Печать" система предложит указать местоположение и имя файла, в который будет произведен текстовый вывод;
· В файл с разделителями Tab информация будет выведена в специальный текстовый файл, который можно использовать для загрузки информации в программы-обработчики электронных таблиц (например, MsExcel), а так же в программы автоматической телефаксовой и E-mail рассылки. Выводимые поля в таком файле разделены между собой символом Tab (код символа 09), записи разделены символом Абзац (коды символов 13,10).

Вывод порядкового номера и разделителя записей:

· Выводить порядковый номер последовательная нумерация выводимых предприятий в процессе печати, начиная с единицы;
· Выводить разделитель отделять выводимую информацию о предприятиях строкой-разделителем.

См. также:

Форматный вывод


Форматный вывод

Режим предназначен для форматного вывода информации о предприятиях из рабочего списка. С помощью этого режима можно реализовать печать наклеек и почтовых конвертов.

Для вызова режима печати нужно перейти к рабочему списку (кнопка "Рабочий список" главного окна) и нажать кнопку "Форматный вывод" или выбрать пункт меню "Файл \ Форматный вывод".

В окне "Форматный вывод" необходимо выбрать размер страницы, на которую предполагается производить печать, и формат вывода. Для каждого типоразмера страницы программа предлагает несколько готовых форматов вывода. При необходимости возможна корректировка формата (кнопка "Редактирование"), а также создание нового на основе уже существующего ("Создать"). Ненужные для работы форматы можно удалить (кнопка "Удалить").

Кнопка "Просмотр" позволяет произвести предварительный просмотр печатаемой информации. Кнопка "Печать" активизирует процесс печати, кнопка "Закрыть" позволяет отказаться от печати и перейти в главное окно программы.

С помощью кнопки "Запомнить" можно запомнить текущий выбранный формат печати; при последующем вызове режима "Форматный вывод" текущим будет именно этот формат.

См. также:

Настройка формата для вывода


Настройка формата для вывода

Выберите наиболее подходящий формат для вывода (например, Наклейки 2 столбца на странице A4, Portreit) и нажмите кнопку "Редактировать".

На вкладке "Страница" окна "Редактирование формата" нужно указать размер наклейки, число колонок и строк на странице, шаг наклеек по горизонтали (Шаг X) и вертикали (Шаг Y), а так же размеры левого и верхнего полей.

При установке размеров в окне "Редактирование формата" следует помнить, что в зависимости от модели используемого принтера, реальные размеры элементов могут несколько отличаться от заданных.

Рекомендуется перед выводом большого количества информации на печать, сделать пробную распечатку с небольшим количеством предприятий и, при необходимости, подкорректировать размеры и координаты выводимых элементов.

На вкладке "Наклейка" можно добавлять, удалять и редактировать элементы, которые будут печататься на наклейке.

Все заданные для наклейки элементы и их параметры перечислены в области "Размеры и координаты".

Для каждого элемента задаются его координаты на наклейке (Х,Y), ширина и высота области, в которой будет выводиться элемент, наименование и размер шрифта, которым элемент будет печататься. Координаты элемента отсчитываются из левого верхнего угла наклейки слева на право, сверху вниз.

Для удаления элемента, его нужно выделить и нажать клавишу Del (Delete) на клавиатуре.

Редактирование элемента производится двойным щелчком мыши на его названии.

См. также:

Добавление нового элемента

Форматный вывод


Добавление нового элемента

Элемент может состоять из произвольного текста и информации из полей базы данных. Произвольный текст, заданный в элементе, будет печататься одинаково на всех наклейках. Информация полей базы данных будет изменяться в соответствии с информацией о предприятиях рабочего списка.

В левой части области "Добавление элемента" перечислены поля базы данных, информацию которых можно вывести на наклейке, и представлена строка для ввода произвольного текста. С помощью кнопок переноса в правой части области нужно сформировать элемент и добавить его к списку элементов, выводимых на наклейке (кнопка Добавить).

Если элемент состоит из нескольких полей базы данных, то при выводе на наклейку информация выбранных полей будет разделена запятой.

Очистить поле формирования элемента можно кнопкой Очистить.

Пример 1

Как на почтовых наклейках распечатать свой обратный адрес?

· в области "Добавление элемента" вкладки "Наклейка" окна "Редактирование формата" нужно ввести свой обратный адрес;
· нажать кнопку переноса справа от строки ввода. Ваш адрес появится в правой части области "Добавление элемента";
· нажать кнопку "Добавить". Ваш адрес появится в списке элементов, печатаемых на наклейке;
· задать для адреса местоположение на наклейке, размер "рамки", в которой будет выводиться адрес, наименование и размер шрифта, которым адрес будет печататься. При задании элементов Вы можете визуально контролировать положение и вид нового элемента в области "Просмотр - изображение наклейки";
· нажать кнопку "Применить" новый элемент запомнится в формате наклейки.

Пример 2

Как на почтовых наклейках распечатать адреса получателей?

· в области "Добавление элемента" вкладки "Наклейка" окна "Редактирование формата" нужно с помощью кнопки переноса последовательно добавить поля, составляющие полный почтовый адрес получателя: <03>Почтовый индекс, <04>Государство, <05>Область, <06>Район, <07>Город, <08>Адрес;
· нажать кнопку "Добавить". В списке элементов, печатаемых на наклейке добавится элемент <03><04><05><06><07><08>. При печати наклеек, вместо номеров полей будет подставлена информация предприятий рабочего списка;
· задать местоположение нового элемента на наклейке, размер "рамки", в которой будет выводиться адрес, наименование и размер шрифта, которым адрес будет печататься;
· нажать кнопку "Применить" новый элемент запомнится в формате наклейки.

См. также:

Форматный вывод